This project is read-only.

Can't add a role

Jan 14, 2014 at 4:35 PM

Most bizarre scenario, and I know it worked before...

I can create a new computer, add a description, MAC address, OSDComputerName, all fine.
As soon as I try to add a role, the app freezes.

I have tried adding the Role straight from DeploymentWorkbench as the same user, works fine.
I then go back to MDT Administrator, I can see that the role has been added, I can even remove it, but I can't re-add it.

Has anybody seen this before??


... Alex ...
Jan 14, 2014 at 4:42 PM
Found my own answer - Sometimes there's nothing like saying the question out loud, no matter how long you've been at it.

The culprit was modifying the settings.ini file - I had changed domainDCs from its default value to e.g.;

Reverting back to the default value brought it back to normal.
Jan 14, 2014 at 4:46 PM
Edited Jan 14, 2014 at 4:47 PM
Ok. So, I'm not sure exactly what went wrong here. Are you saying it won't work to add a role to a computer if multiple domains are used in settings.ini? Or do you mean that one of your domain entries where in fact a non-existent domain?

Jan 16, 2014 at 10:19 PM
Hi Chris,

Sorry I didn't reply sooner - Took me a while to go back to cross-check.

So, it turns out that one of the domain I had in isn't trusted (yet), and that was the one causing issues.
If I have our domain only, the OU check works fine.
If I have the non-trusted domain only, I get an error saying that the script took too long, and am prompted whether I want to stop it.
If I have both domains, it freezes.

So for the time being, I have turned off the OU check.

Hope this helps.

... Alex ...
Jan 17, 2014 at 7:13 AM
Ok. I believe the fact that you're using an untrusted domain causes this issue. I've not gotten any complaints about OU validation not working with multiple domains in any other case. Let me know there's still issues, when you have made the second domain trusted.